I've Got a Gas Problem

The friendliest place on the web for anyone that enjoys cooking.
If you have answers, please help by responding to the unanswered posts.

BeeRich

Sous Chef
Joined
May 20, 2009
Messages
583
Location
Toronto, Canada
Napoleon PT450 Infrared Grill on house natural gas. Owned it for 13 years. Noticed all elements have low flow rate for gas. Double left burner, single right burner, infrared burner, and rotisserie horizontal burner, all have low flow rates.

I've blown out the IR venturi, and same thing. So it's in the main gas manifold or the gas line. The gas line has a ball valve and a disconnect I have access to. I am seeing a threaded connection from the owner's manual diagrams (see attached)

What should I check? How can I clean out the manifold? I don't have compressed air access. I have a venturi brush (spiders) but I don't know how to get into this horizontal tube.

Some pics attached. Looking forward to your input. Cheers
 

Attachments

  • Screen Shot 2022-06-18 at 1.01.01 PM.jpg
    Screen Shot 2022-06-18 at 1.01.01 PM.jpg
    20.2 KB · Views: 18
  • Screen Shot 2022-06-18 at 1.01.18 PM.jpg
    Screen Shot 2022-06-18 at 1.01.18 PM.jpg
    14.3 KB · Views: 19
  • Screen Shot 2022-06-18 at 1.01.45 PM.jpg
    Screen Shot 2022-06-18 at 1.01.45 PM.jpg
    19.3 KB · Views: 20
  • Screen Shot 2022-06-18 at 1.02.19 PM.jpg
    Screen Shot 2022-06-18 at 1.02.19 PM.jpg
    16 KB · Views: 20
  • Screen Shot 2022-06-18 at 1.02.34 PM.jpg
    Screen Shot 2022-06-18 at 1.02.34 PM.jpg
    20.4 KB · Views: 21

Latest posts

Top Bottom